]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - sys-apps/man/man-1.6g-r2.ebuild
sys-apps/man: Use absolute paths in makewhatis cron job.
[gentoo-fixes.git] / sys-apps / man / man-1.6g-r2.ebuild
similarity index 85%
rename from sys-apps/man/man-1.6g-r1.ebuild
rename to sys-apps/man/man-1.6g-r2.ebuild
index 0911511a443f043731e6aca5755f2eab0e9abe3c..d4574946b723b23bfc4b3d43fbe348b1049f3a69 100644 (file)
@@ -92,11 +92,17 @@ src_configure() {
 
        echoit \
        ./configure \
-               -bindir="${EPREFIX}"/usr/bin \
-               -confdir="${EPREFIX}"/etc \
+               -prefix="$EPREFIX/usr" \
+               -confdir="$EPREFIX/etc" \
                +sgid +fhs \
                +lang ${mylang} \
                || die "configure failed"
+
+       cat >makewhatis.cron <<EOF
+#!/bin/sh
+
+exec nice $EPREFIX/usr/sbin/makewhatis -u
+EOF
 }
 
 src_install() {
@@ -109,7 +115,7 @@ src_install() {
 
        # makewhatis only adds man-pages from the last 24hrs
        exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/makewhatis.cron makewhatis
+       newexe makewhatis.cron makewhatis
 
        keepdir /var/cache/man
        [[ -z ${EPREFIX} ]] && diropts -m0775 -g man
@@ -128,19 +134,6 @@ pkg_postinst() {
 
        echo
 
-       local f files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
-       for f in ${files} ; do
-               [[ ${f} == */etc/cron.daily/makewhatis ]] && continue
-               [[ $(md5sum "${f}") == "8b2016cc778ed4e2570b912c0f420266 "* ]] \
-                       && rm -f "${f}"
-       done
-       files=$(ls "${ROOT}"etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
-       if [[ ${files/$'\n'} != ${files} ]] ; then
-               ewarn "You have multiple makewhatis cron files installed."
-               ewarn "You might want to delete all but one of these:"
-               ewarn ${files}
-       fi
-
        if has_version app-doc/heirloom-doctools; then
                ewarn "Please note that the /etc/man.conf file installed will not"
                ewarn "work with heirloom's nroff by default (yet)."