]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
Remove media-gfx/uniconvertor.
[gentoo-fixes.git] / media-gfx / uniconvertor / uniconvertor-2.0_pre379-r1.ebuild
diff --git a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
deleted file mode 100644 (file)
index f7feeb9..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright © 2017 Nick Bowler
-# License GPLv2+: GNU General Public License version 2 or later.
-# There is NO WARRANTY, to the extent permitted by law.
-#
-# This file is a modified version of the original ebuild from Gentoo,
-# covered by the following copyright and permission notice:
-#
-#   Copyright 1999-2017 Gentoo Foundation
-#   Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Convert vector graphic file formats like .cdr, .svg, wmf and more."
-HOMEPAGE="https://sk1project.net/modules.php?name=Products&product=uniconvertor"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-
-KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2"
-IUSE="imagemagick"
-
-RDEPEND="
-       dev-python/pycairo[${PYTHON_USEDEP}]
-       imagemagick? ( media-gfx/imagemagick:= )
-       media-libs/lcms:2
-       dev-python/pillow[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       app-text/ghostscript-gpl"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-import.patch
-       "${FILESDIR}"/${P}-test.patch
-       )
-
-python_prepare_all() {
-       local wand
-
-       if use imagemagick; then
-               PATCHES+=("$FILESDIR/$P-libimg.patch")
-               wand=$(pkg-config --libs MagickWand | sed -e "s:^ *::g" -e "s: *$::g" -e "s:-l:\':g" -e "s: :',:g" -e "s:$:':g" -e "s:,'$::g")
-       fi
-
-       distutils-r1_python_prepare_all
-
-       if use imagemagick; then
-               sed \
-                       -e "/libraries/s:'MagickWand':${wand}:g" \
-                       -i setup.py || die
-       fi
-
-       ln -sf \
-               "${EPREFIX}"/usr/share/imagemagick/sRGB.icm \
-               src/unittests/cms_tests/cms_data/sRGB.icm || die
-}
-
-python_test() {
-       einfo ${PYTHONPATH}
-       #distutils_install_for_testing
-       cd src/unittests || die
-       ${EPYTHON} all_tests.py || die
-}