]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - dev-python/pygtk/pygtk-2.24.0-r6.ebuild
Work around python-r1 eclass dropping python2.
[gentoo-fixes.git] / dev-python / pygtk / pygtk-2.24.0-r6.ebuild
similarity index 78%
rename from dev-python/pygtk/pygtk-2.24.0-r5.ebuild
rename to dev-python/pygtk/pygtk-2.24.0-r6.ebuild
index c23bff38d1dcb54f1294d9aa4139ce183d2356e7..a73bcd51fea2597cf953f92b22d587e09fb058e6 100644 (file)
@@ -1,10 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
+# Copyright © 2021 Nick Bowler
+#
+# License GPLv2+: GNU General Public License version 2 or any later version.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+#
+# This is a modified version of the original ebuild from Gentoo GNU/Linux,
+# covered by the following copyright and permission notice:
+#
+#   Copyright 1999-2020 Gentoo Authors
+#   Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
 
 GNOME_TARBALL_SUFFIX="bz2"
 
+_PYTHON_ALLOW_PY27=1
 PYTHON_COMPAT=( python2_7 )
 
 inherit autotools flag-o-matic gnome2 python-r1 virtualx
@@ -27,14 +37,11 @@ RDEPEND="${PYTHON_DEPS}
        >=x11-libs/gtk+-2.24:2
        >=dev-python/pycairo-1.0.2:2[$PYTHON_USEDEP]
        >=dev-python/pygobject-2.26.8-r53:2[$PYTHON_USEDEP]
-       >=gnome-base/libglade-2.5:2.0
-"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       doc? (
-               dev-libs/libxslt
-               >=app-text/docbook-xsl-stylesheets-1.70.1 )
-"
+       >=gnome-base/libglade-2.5:2.0"
+DEPEND=$RDEPEND
+BDEPEND="virtual/pkgconfig
+       doc? ( dev-libs/libxslt
+               >=app-text/docbook-xsl-stylesheets-1.70.1 )"
 
 PATCHES=(
        # Fix declaration of codegen in .pc