]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - app-emulation/wine-vanilla/wine-vanilla-4.0.4.ebuild
app-emulation/wine-vanilla-4.0.4: Fix build with GCC 10.
[gentoo-fixes.git] / app-emulation / wine-vanilla / wine-vanilla-4.0.4.ebuild
index a516ce034e223478c4cb55397bc8915b712a90f5..c8112e655f54802952ee66ccb281ef090e79f7e2 100644 (file)
@@ -139,6 +139,7 @@ usr/share/applications/wine-uninstaller.desktop
 usr/share/applications/wine-winecfg.desktop"
 
 PATCHES=(
+       "$FILESDIR/$PV-configure-fixes.patch"
        "${PATCHDIR}/patches/${MY_PN}-1.5.26-winegcc.patch" #260726
        "${PATCHDIR}/patches/${MY_PN}-1.9.5-multilib-portage.patch" #395615
        "${PATCHDIR}/patches/${MY_PN}-1.6-memset-O3.patch" #480508
@@ -353,6 +354,7 @@ src_configure() {
 
        export LDCONFIG=/bin/true
        use custom-cflags || strip-flags
+       append-flags -fcommon
 
        multilib-minimal_src_configure
 }